Kangry.com [insert cool graphic here]
home | Topics | Logout | Search | Contact | ?? Kangry ?? | Bandwitdh
Topics:
DVR
nvrec
Mplayer
Links
Misc
Commands
Humor

Name

Password

New user

uploaded files
(linux_command_line)-> [Samba] Links followed to my local filesystem submited by Russell Mon 07 Mar 05
Web kangry.com
in reply to this message

I have the same problem. I have an old Redhat 7.3 box that I am trying to replace with a FC3 box..

when the FC3 box mounts samba directories the symlinks show up as symlinks ( and are invalid as they point to non-local paths)

When the RedHat 7.3 box mounts the same directories, it is unaware that the symlinks are not directories. For years I have accumulated symlinks that share files between different projects. So, it's not an easy option to "stop using symlinks"

I tried installing the old version of samba on the new machine, ( rpm -U samba-client-2.2.7-3.7.3.i386.rpm samba-common-2.2.7-3.7.3.i386.rpm --force --nodeps ) it complained but seemed to work. But even with the OLD rpms the symlinks still show up as symlinks. I am at wits end.

related link in bugzilla

If that is the problem, is there a quick and dirty trick to make the server think all clients are windows clients? ( clearly not an elegant solution but would solve the current crisis )


Not long after posting the above to a mailing list I got a reply from Jeremy Allison :
Yeah, you could turn off the unix extensions ("unix extensions = no").
That would do it. Hmmmm. I need to think about this issue a bit....

Jeremy.

And it worked. .. behold the power of the internet


Add comment or question...:
Subject:
Submited by: NOT email address. Leave blank for anonymous    (Spam Policy)

Enter Text: (text must match image for posting)




This file (the script that presented the data, not the data itself) , last modified Wednesday 03rd of December 2014 09:40:39 AM
your client: CCBot/2.0 (http://commoncrawl.org/faq/)
current time: Sunday 30th of April 2017 02:35:49 PM