Kangry.com [insert cool graphic here]
home | Topics | Logout | Search | Contact | ?? Kangry ?? | Bandwitdh
Topics:
DVR
nvrec
Mplayer
Links
Misc
Commands
Humor

Name

Password

New user

uploaded files
(linux_command_line)-> (Parent)->samba 12351: tree connect failed nosuchshare submited by Russell Mon 23 Aug 10
Web kangry.com
after seting up a new server with samba I got this error:
12351: tree connect failed: ERRDOS - ERRnosuchshare (You specified an invalid share name) SMB connection failed
when I tried to mount the shared directory on the server. This was in-spite of the fact that the directory was listed with smbclient -L <server_name>
I knew the directory existed, because I chose it using the GUI config tool (system-config-samba) we were not dealing with a typeo in the path.

I tried several things, Turned off the firewall ( I had already enabled the smb connection ports) , Turning off SELINUX ( a common cause of problems like this) ..

After an hour or more of banging my head aginst this I checked the directory permissions.

The directory I am sharing is a subdir of a user dir. (/home/username/shared_path ) I had some vague memory of this being an issue with apache sharing the http-public dir of a user. It turns out that the parent directory must be world readable (chmod 755 or 744 ) for samba to be able to read it.

so I fixed it with:
sudo chmod 755 /home/username
I post this here in hopes that someone else might spend less time on this error.


Add comment or question...:
Subject:
Submited by: NOT email address. Leave blank for anonymous    (Spam Policy)

Enter Text: (text must match image for posting)




This file (the script that presented the data, not the data itself) , last modified Wednesday 03rd of December 2014 09:40:39 AM
your client: CCBot/2.0 (http://commoncrawl.org/faq/)
current time: Wednesday 26th of April 2017 03:26:51 PM