Kangry.com [insert cool graphic here]
home | Topics | Logout | Search | Contact | ?? Kangry ?? | Bandwitdh
Topics:
DVR
nvrec
Mplayer
Links
Misc
Commands
Humor

Name

Password

New user

uploaded files
(nuvrec)-> Service error "atd dead but subsys locked" submited by Russell Sun 02 Oct 05
Edited Wed 06 Sep 06
Web kangry.com
so I had a failure of my home built tivo where it stopped recording files. This was all assocated with a disk full state on my working hard disk, but what sucked was that my recovery from the process took much longer than I was happy with.

You see when the disk was full, lots of working files could not be created or were created with zero size. Even after I cleared disk space I still got some failures. One really nasty problem I had dealt with the at deamon. I kept getting this error:
atd dead but subsys locked
which ment that the schedule system was not running. Jobs were not being started, programs were not being recoreded. Essentialy. the tivo was shut down.
I tried:
[root@vidcap run]# /etc/init.d/atd restart
Stopping atd: [FAILED]
[root@vidcap run]# /etc/init.d/atd status
atd dead but subsys locked
I found some zero size files in /var/spool/at which I suspected migh be the problem. I removed these. Still it didn't work. I even tried rebooting. (something I NEVER find required under linux. Still no luck. Then I found here that I simply needed to create a dummy atd.pid file ( in /var/run ) and that would enable me to restart the daemon properly.

Well in practice, this didn't work eather. ( atleast not on Redhat 7.3 with a patched 2.4.19 kernel ) It seems that the pid in the /var/run/atd.pid file must exist.

If it is fake, I get:
[root@vidcap run]# /etc/init.d/atd restart
Stopping atd: [FAILED]
[root@vidcap run]# /etc/init.d/atd status
atd dead but pid file exists
So did a ps uaxf and noted the number of a process I knew I didn't need. ( I used the process for /sbin/mingetty tty6 ) and I put this process number in /var/run/atd.pid. echo 1234 > /var/run/atd.pid (use a number that is being used by something expendable: ps axf |grep tty|grep -v grep )

Now when I do :
[root@vidcap run]# /etc/init.d/atd restart
Stopping atd: [ OK ]
Starting atd: [ OK ]
[root@vidcap run]# /etc/init.d/atd status
atd (pid 25270) is running...
As I suspected the system properly restarted the process for /sbin/mingetty tty6. But I wouldn't have needed the 6th consol session, for a computer that I almost never physicaly walk over to. ( I deal with it almost exclusively via ssh )


Add comment or question...:
Subject:
Submited by: NOT email address. Leave blank for anonymous    (Spam Policy)

Enter Text: (text must match image for posting)




This file (the script that presented the data, not the data itself) , last modified Wednesday 03rd of December 2014 09:40:39 AM
your client: CCBot/2.0 (http://commoncrawl.org/faq/)
current time: Wednesday 28th of June 2017 03:00:43 AM